Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[FIXED] Linux VR

edited May 23 in Suggestions
UPDATE: Got it working. The only thing I did differently was launching it through Steam's desktop interface, not from SteamVR Home. This seems to solve the issue. So you can disregard the rest of this thread.

I want to play this in VR, but while the game works nearly perfectly on Linux (the green and red buttons at the start lack text) with Wine, the game never detects the headset even if you try launching it through SteamVR. Steam does support VR on Linux (for a year or two) but only with the native Steam for Linux client. While all SteamVR games (except Croteam's) are Windows-only, Valve created a fork of Wine called Proton which allows Windows SteamVR games to work on Linux. In particular, they have whitelisted Beat Saber, DOOM VFR, and Google Earth - there are other games that work just fine, though. You can play non-Steam games with Proton, but besides what's in the next sentence, I don't know what other VR-compatible games aren't on Steam so I haven't been able to test.

Vivecraft, a Minecraft mod, uses OpenVR. And it works on Linux. That's Java, not Unity, though. Valve open sourced one of their recent demos, which uses Unity, so that may be interesting to look at... but I don't know if anyone's tried building it for Linux, and Knuckles (now Index Controllers) aren't even out yet.

Some other useful links:

https://github.com/ValveSoftware/openvr (some versions of Unity come with an older version of OpenVR that doesn't work with Linux fyi)

https://github.com/ChristophHaag/soundstagevr - Google open sourced Soundstage VR, and this guy made it work on Linux



Looking into this a bit more later.



Comments

  • As the Yiffalicious team is very small, I don't think it would be time well spent on something for an operating system that isn't even supported officially.
    Just install Windows 10 on a partition for games, you can just use it without license or buy a cheap code on ebay for less than 3 o 4 USD. Downloading the iso is free from Microsoft itself and you can use any linux tool to burn the ISO to an USB stick and install from there. After installation you can reinstall grub to have a faster booting to Linux (much faster than the Microsoft OS selector)
  • Nah, not going to use Windows. I dropped it for specific reasons I don't think I need to get into here. Thanks for the suggestion anyway. If I ever have more progress getting this working with Wine or Proton I'll let yall know.
  • Update: Got it working great now. Might have been an update fixed my issue? I don't know, but there's not a problem anymore!
  • You can fix the text problem (if you haven't already) by downloading the Windows default fonts within wine.
  • Oddly enough the problem doesn't occur in VR mode! Thanks for the tip though, I'll do that if I run into other font issues.
  • Hey.. um.. I'm a little confused how you got this to work?
    Could you explain what you installed?

    I added yiffalicious non-steam game to steam-runtime library but launching it does nothing.
    I have fully working VR through steamvr atm and I just installed openvr on my system.
    Not sure what do do next though.

    Also I'm on arch.
Sign In or Register to comment.