Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Fur Shade on nipple area, Preset brush being funny, Mask UI messed up, and more.

edited November 8 in Issues
I do not think this shading bug around nipple area is exclusive to the shade made from Fur.

This circular glitch around the nipple arena is present among other texture/shade related functions.
The current work around this is, not use excessive shade, hide the seams by added a length of fur over it.

I remember this being the case for Detail textures

Its that nipple arena making stuff behave differently. Could be a big tedious task to fix if its per model related.

---------------

Issue 2 is a very minor one. When creating a brush preset, the blue "Create" button is "Delete". ;)

---------------

Horrendus UI glitch when selecting masks.

I dont know if its just me, the ui functions perfectly fine but it does make it harder to see what I am selecting.



-----------------

TextureMasks have changed, and so the Texture that was used on the body and maybe hands and feet have vanished. But the texture on head stayed for some reason.




-------------

Il update and bump this thread for any more issues that I find.

Comments

  • odesodes Administrator
    Nipple issue:

    Ah, this is tricky. The nipple is rendered with separate mesh and with tessellation. What you're seeing is the tessellated mesh rendering over the other one. Tessellation is required to show the nipple, but it will interfere with fur.

    Need to think about this one.

    ----------

    Issue 2 is a very minor one. When creating a brush preset, the blue "Create" button is "Delete". 


    lol, wut. I did not catch a word of that. What blue button? We have a green button with a + on it, and a red one with an x.

    ----------

    UI Bug


    I'm unable to reproduce this.

    Does it happen on all characters or just a specific one? 

    ----------

    TextureMasks:

    Ah, stupid mistake. Paths have changed (as you may have noticed), and I needed to add a former path loading for that. I did, for all properties except the first one.

    Issue is fixed.

    ----------

    Thanks for bringing these up.
  • Issue 2 is a very minor one. When creating a brush preset, the blue "Create" button is "Delete".

    Ok, what I meant was, when you click to create a new brush preset and naming it, there is a big Cancel button and a blue OK button. However, I somehow managed to have it say Delete instead of OK. A very minor bug that I almost did not notice out of sheer habit of affirming to a blue button. I dont know how to get the "Delete" back. But I swear it said it D:

    ----

    UI Bug


    I'm unable to reproduce this.


    Same. Just logged back in after a while and It appears to work fine. Previously, it would show itself like that even after restarting the app. I happen to not have it atm. I have a sneaking suspicion that it could be due to Alt+Tab.

    Nipple issue: ... Need to think about this one.

    In my opinion, I dont think its that big of an issue. There are many ways to work around it within the App. But I think it helps to be aware of it since so many things affect it at this point.

  • odesodes Administrator
    I'm writing from my phone so sorry for being brief.

    The thing is though, we don't have any blue buttons AFAIK? They're all either pink/purple or gray/black. So everything about that is just super odd!

    OK, let me know if it happens again!
  • The thing is though, we don't have any blue buttons AFAIK? They're all either pink/purple


    Yeah sorry, got all colour blind and refereed the purple as blue. But I AM NOT COLOUR BLIND I swear! D:


  • edited November 8
    Ok, I got the horrendus UI glitch once again a few times. Still dont know what causes it, but now Im suspecting its the heavy load that Fur Authoring takes. So combine the lag that occurs at times with maybe alt+tabbing etc the window fudges up. Restarting the app fixes it despite what I said earlier.

    ----

    I managed to almost replicate the "delete" button but something else happened. No screenshot, sorry, but the entire blurred background snapshot something hazy when the menu pops up. Things are getting weirder and weirder.

    ----

    After spending a lot of time with Fur Authoring, ive also managed to get locked out of Ctrl+Z again, while also not be able to press R for "Reset select pose circle thing" on the poser. Resetting the App fixes the issue. Saving the character before hand does not corrupt the character either so its all good. The cause may be due to the heavy load from Fur Authoring.

    In other words, my PC is not strong enough to flawlessly run the editor without hitches :P
  • I HAVE IT


    Pressing Delete creates the Preset, because it actually means to say Ok. While I have this, I also have the horrendus UI glitch on the masks window. I think the two are related!

    It is also definitely because of the heavy load when authoring Fur as I started getting the mask window glitch with this after lagging hard at a certain point lengthening the fur with a brush.
  • odesodes Administrator
    If you can give me your output_log when it happens, that would be super helpful!!
  • odesodes Administrator
    The UI bug with the lines reminds me of another bug that essentially produced the same artifacts (although in a different context). For whatever reason, drawing lines using GL after everything has been rendered seems to be a no-no. I'm not sure if I'm at fault here, or Unity, but I have submitted a bug report to them.

    In any case, I've made a work-around using regular UI elements and line renderers to draw lines instead. This doesn't seem to produce the undesired artifacts. I'm fairly certain this bug is fixed.

    So the only thing remaining right now is that weird "delete" bug and fur slowdown. They may be related, as the only reason I can think of why it saying "delete" is because the code to set the text to something different was never reached because of an exception. That exception may be what's causing the fur to render slowly as well.

    But I need output_log.txt to have a chance of solving that.
  • odesodes Administrator
    The line drawing I'm referring to is the set clipping border function btw. So if you think that breaks your app, you could try using it.
  • The Set Clipping Border tool actually makes things much easier, I only lag while using the Sculpt tool on odd areas (The crotch). While the Set Clipping Border Tool is flawless and I dont lag at all. So all good there in my books.
  • odesodes Administrator
    Have you had any luck in reproducing that "Delete" bug?

    I'm in the process of making a patch, and it would be great to have that bug solved, but I need an output_log or steps to reproduce ...
  • I havent, But il go and stress test that right now!
  • That was easier than expected, I Stressed the fur authoring tool, went into pose and back, put my camera at a fur intesive spot to lag my app a bit and then voila, got it again. Sending the log through PMs
  • odesodes Administrator
    Thanks for sharing that!

    However, there seems to be nothing in the logs to help! D:

    Can you record the whole procedure to cause this bug? 

    I'm sorry for being a pain, but I just can't seem to cause it!
  • edited November 12
    Now I know how to replicate it for real.

    Open up fur authoring, make a brush preset, see if it says OK
    Go to pose mode, Bring up the window to delete a photo
    You dont need to delete, but press to delete and bring out the final confirmation, just come back to fur authoring brush preset and itl now say Delete instead of Ok


    I will try to be better at hunting these bugs and figuring them from now on. While I use the app so much, might as well also get better at helping you improve it.

    (Wait, have I said this before?)
  • odesodes Administrator
    Thank you so much for that! I can replicate it now. This helps immensly! :)

    Thanks again!
  • odesodes Administrator
    The issue is solved. Really stupid mistake. :D

    Thanks again. I'll probably publish a new build very soon.
  • Thanks for the hard work!
Sign In or Register to comment.