Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

0.3.4b mac problems

edited 6:08AM in Issues
I have been using wine/ wineskin to use Yiffalicious on my mac. With most recent version, it gets stuck on the loading screen. Does anybody have any answers? -Thanks.


  • edited 6:08AM
    I'm going through the same junk on my mac. The fact is, it was probably an eventuality that some version of Yiffalicious would be incompatible with either Macs or Wine. Neither the working nor stable versions of Wine Bottler available right now will run it. I assumed though that my old beater had just been outstripped graphics-wise. Is your Mac more recent/newer?
  • edited 6:08AM
    My mac is a late 2010.
    The strange this is that it worked with the 0.3.4, but not with 0.3.4b. It is not a server problem because I still have 0.2.4 and it works. When I booted up my windows 7 emulator 0.3.4b works. Even if I start 0.3.4b on the lowest settings, it won't start up. So something happened between 0.3.4 and 0.3.4b
  • edited September 2015
    v0.3.4b changes:
    Bug fixes
    -Forgot to increment version check inside app...

    Given that a version check is the only change that officially happened between 0.3.4 and 0.3.4b is a version check, I would tell you to check your firewall/antivirus... However, you're running Macs and I have no idea if these even have those. Maybe Wine has its own firewall/antivirus? You could also try redownloading Yiffalicious or maybe even simply using the 0.3.4 version and ignoring the "Download the latest version" prompt. But then 0.4.x might not work. If I were you, I'd either get a PC or use the emulator someguy's using.

  • odesodes Administrator
    edited 6:08AM
    This is interesting. I'm not a wine expert, but open the equivalent to regedit and do this:

    1. goto HKCU\Software\Yiffalicious crew\Yiffalicious
    2. Add a string entry for "leveltoload" with the value "spa"
    3. Try to launch the app again

  • edited 6:08AM
    Macs don't allow anything as streamlined as using regedit or an equivalent to mess with a program's code, 'cause fuck Jobs. The next best thing are .plist files in the Library. I dug around for a bit and did find a "yiffalicious crew_yiffalicious" folder, but it seems to be empty. I did open "mainData" from the "yiffalicious_Data" folder and did find this:
    Assets/#/Levels/warning.unityAssets/#/Levels/alpha.unityAssets/#/Scenes/loading.unity-Assets/#/Levels/Ocean house/ocean_house.unity!Assets/#/Levels/_INIT_/init.unity,Assets/#/Levels/Locker room/lockerroom.unityAssets/#/Levels/Spa/spa.unity*Assets/#/Levels/Greetz/TextAnimation.unityAssets/#/Scenes/

    Coding is sausage to me. Is this of any use?
  • odesodes Administrator
    edited 6:08AM
    Archmancer8 said: Macs don't allow anything as streamlined as using regedit

    No, but wine does! I'm pretty sure Wine comes with regedit, that is used for apps running on Wine. 

  • edited 6:08AM
    Oooooh...I have learned something today...
    Winebottler doesn't allow access to the registry at least, so I tried someguy's path with wineskin. That new string does work. The other two levels load fine, so I'm guessing there's something in the beach house which macs don't like.
    However, now I'm struggling with one of wineskin's beloved mouse bugs; I can drag and drop anchors when set to 'move', but I can't rotate anything. Nor can I zoom or rotate the camera. Sounds like it's time to save up for that PC -.-
  • odesodes Administrator
    edited 6:08AM
    You do know about bootcamp, right? Macs use PC parts nowadays so you can install windows on it.
  • edited 6:08AM
    Yes I have considered bootcamp in the past, but I don't consider buying a copy of Windows just to install on this old beat up Mac to be worth it. I've been meaning to get a PC desktop for a while anyway. Thanks for trying to help, really, but it's fine.
  • edited 6:08AM
    NOTE: I have resolved the issue! Mac users, please see the step by step process in my other post ( and it will work, no emulator, no boot camp, no crossover!
  • edited 6:08AM
    same here, I've tested on my windows laptop to see if was a bug, but it ran it after a got damn long time of loading; so I thought I just had to wait for it to load on my iMac as I did on my windows laptop, but to no avail.
Sign In or Register to comment.