Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

FurryVNE.exe has stopped working.... has not worked from the start and searching the forums has yielded no answers to my issue.

I open the program and get past the processing screen and then about 5 seconds after the music starts, I get a popup window saying FurryVNE.exe has stopped working....has never failed to show me that popup as of yet. 

I am using windows 8 64bit, 8gb ram with an RX 580 graphics card. My drivers are up to date. I can run Yiffalicious, though that one is prone to crashing as well, but only if i'm trying to create my own interaction.   

Here is a link to the log:

Any help would be greatly appreciated. 


  • odesodes Administrator
    edited June 20
    Thank you for making us aware of this issue.

    Unfortunately, the logs don't tell us anything useful. I suspect some kind of incompatibility with compute shader, but without further testing, it's impossible to know what is wrong.

    From experience, I know the process of blindly making changes to the code where we suspect where the issue lies, building, sending to client, waiting for them to test it, send back log, is a very slow process. This one iteration can take from hours to days, depending on how schedules align. Last time we ran into something like this, we ended up buying similar hardware to the client's, and luckily we were able to reproduce the bug there and solve the problem.

    I have an AMD laptop with the Vega GPU series, and I can run the app successfully on it. I understand you use a RX 580 GPU, aka Polaris, which is Vega's predecessor. I don't have access to this hardware at this particular moment, but I can place an order on a Polaris GPU. Retrieving it, installing and testing will take some time though.

    In the meantime, can you give us a bit more elaborate description of what hardware you are using? That is, what CPU are you using?

    All the best.
    - odes
  • odesodes Administrator
    I might add it's a bit worrying that Yiffalicious crashes for you. That definitely shouldn't happpen, and might point to a more serious issue in your system, either software (OS) or hardware.
  • odesodes Administrator
    BTW, what version are you on? The 2021-05-14 release did fix some crashing issues on other systems. Are you using that release or an older one?
  • Hey odes, Thanks for responding. 

    My cpu is Athlon X4 880K 4Gz. 
    FurryVNE_2021-05-14 is the version I am trying to start. 

    I don't know if this will help but here are the details copied from the FurryVNE has crashed popup window:
      Problem Event Name: APPCRASH
      Application Name: FurryVNE.exe
      Application Version: 2018.4.32.42077
      Application Timestamp: 6024065e
      Fault Module Name: UnityPlayer.dll
      Fault Module Version: 2018.4.32.42077
      Fault Module Timestamp: 6024070c
      Exception Code: c0000005
      Exception Offset: 00000000011b9708
      OS Version: 6.3.9600.
      Locale ID: 1033
      Additional Information 1: 7134
      Additional Information 2: 71340a44b48ef436eee85c8106089ca3
      Additional Information 3: cada
      Additional Information 4: cada55c810ed2378a1bc74b78001d98e

    Would you happen to have access to the Radeon settings? I added FurryVNE to it so that maybe I could tweak a few settings and hopefully....get it to start. But I am not sure what to set for settings like the Ani-aliasing, Morphological filtering, Anisotropic Filtering, Surface format Optimization, OpenGL triple buffering, Shader cache, and Tessellation mode. (I would upload screenshots of this stuff if I knew how....but i am not the smartest when it comes to

    I know this is not the correct place for the Yiffalicious logs, but I am hoping that maybe....just maybe... that you are able to get a little insight as to why things are crashing for both programs.  
    Here is the pastebin output_log for Yiffalicious after the most recent crash..
    And here is the error file..

    I am not sure how how to get you that crash.dmp file though... 

    Whatever information you need, I will try to get for you so your able to troubleshoot. I know how much of pain troubleshooting can be, even more so with limited data. 

    Again, thanks for your help!! 

  • odesodes Administrator
    edited June 21
    Did the FurryVNE crash also have a "error file"? It seems to contain some useful information.

    It's weird because this crash seems to originate from Unity engine itself.

    I did find this line in the error log:
    Write to location 623f5a40 caused an access violation.

    Being unable to write to a location usually signifies a memory issue of some sort - either running out of it our trying to write to memory that hasn't been assigned to the application.

    And then there's this:
    134217728 MB user address space [134216541 MB free].

    That is absolutely ludicrous. That's 132 TERRA BYTE of memory. I'm not sure if HDD is meant by this, but even so, are there even consumer market HDD drives with 132 TB memory... ? This seems VERY odd. There's no wonder that the app crashes if it's trying to write to a location that doesn't exist, since this memory space is absolutely bonkers.

    With "address space", RAM is almost exclusively implied. So it seems very strange indeed.
  • no, the FurryVNE did not produce an error file. (I wish it did...) 

    Concerning the memory, i have no idea where it got that number from but my systems reports 8GB of ram which is what I installed. (though if I try to add more, my system suffers random crashes for some reason. Tried to expand it awhile back with an additional 8GB of the same type and speed for use with unreal engine. Not sure what the issue is but I thought that memory of the same type, speed, and timings were compatible with each other.. The only thing that did not match was the company.)  And there is 8GB on the graphics card. 

    My hard drive space is no where near that amount either. I have:
    C: = 500GB
    F:(Game Drive) 2 - 500GB SSD's configured in raid as one drive
    and 2 external 2TB hard drives for all other stuff. 

    Currently I got yiffalicious running in the background and it's memory usage is 580MB or the system say anyway. I've been trying to reproduce the error that causes it to crash when I am editing interactions, thought it was related to editing values on the 1st snapshot....but that does not seem to be the case. And I've been playing around in the editor for last couple hours learning the in's and out's of editor interactions with no issue now. 

    ok... I just tried running FurryVNE with the task manager open and it ramps up to about 1.6GB before leveling off till it crashes. (that popup window says the fault module is the UnityPlayer.dll.)  No where near stressing my PC out for ram. Just idling....using about 2.7GB and thats with Brave and Discord running.

    Some things i've tried today...
    Running a registry cleaner after deleting FurryVNE and reinstalling it....
    Ran a driver check for outdated drivers... CCleaner says my graphics drivers are out of date, but Radeon, which manages my graphics drivers, says they are up to date.. I am not sure which to believe. Windows also says my graphics drivers are up to date. 

    I am gonna go slap the Duck for any information about unityplayer.dll faults and see what he quacks. 

    Let me know if you need any additional info or you want me to try something..
    As alway..Thanks for your help 

  • The Duck talked.....
    Some of that info seem strangely familiar regarding the access violation and the amount of memory available?
    Seems it yielded a possible culprit in regards to the crashing. Gonna try switching my ram over to stock speeds in the bios and see what that yields.. 
  • odesodes Administrator
    edited June 21
    Yeah it seems like illusive issue tied to hardware somehow.

    I made this post on Patreon. Hopefully someone can give their experience:

    At least then we can rule out the GPU.
  • update....after switching all my ram settings to auto....still no go. I think my ram has to run the XMP profile because of they type it is...DDR3-2400 and that is the only profile which matches the timings for the ram. 

    Thanks for posting that. I hope it's not the GPU, it seems that there is a shortage of them recently... 

    I will keep digging on my end as well 
    Thanks again

  • odesodes Administrator
    Some users responded in the Patreon thread who have similar GPU hardware to you, and it seems to work fine for them. So I don't think it's the GPU.

    I'm sorry, I really don't know where to go from here since it's seemingly a Unity engine issue, and I don't have access to its source code. :(
  • i'm not sure where to go from here either. I did connect the visual studio debugger to the FurryVNE.exe last night and it seems to be the GameAssembly.dll kicking the error, but without the .PDB files associated with those DLL's, a proper debugging is near impossible.
    This does not seem to be an isolated issue either, there is a lot of other unity games where users are experiencing the same issues with those DLL's. 
    There is an up side to all this...
    1. I now have 16GB of ram installed in my system running crashing at all.
    2. Yiffalicious is also working great with no recent crashes and i was able to actually complete a whole interaction last night and play it. (think the issue there was the user didn't know how to properly edit and kept doing things the program found intolerable.)

    If your able to get me the PDB files associated with the UnityPlayer.dll and GameAssembly.dll, I can try debugging the game through Visual Studio again and see exactly where and what is kicking the fault for my PC and provide that feedback so a fix can be created. 

    Despite not being able to get it up and running, you were still a great help so Thank You for that odes. Now I can resume my learning in Unreal Engine which was near impossible due to the lack of RAM available for projects.

    I will keep my eye on my posting here so if you run across anything that may help, please post it. 

    Thanks again odes.  
  • odesodes Administrator
    edited June 21
    I can give you the GameAssembly.pdb but afaik UnityPlayer.dll is something precompiled that is simply shipped with Unity, so you can't access its pdb.

    I'll send GameAssembly in PM.

    Actually, since build has changed I'm sending a whole new build to you.
  • Awesome sauce!! I will take a look at it tonight when I get home from work.

    You rock odes!
Sign In or Register to comment.